Print this Page

What do I need to use the app?

  • An e-Branch User ID which must be acquired via a desktop or laptop. It cannot be created on the mobile app itself.
  • iPhone 3GS or higher
  • iPod Touch 4G or higher
  • iPad
  • Smartphones and tablets with the Android 2.3.3 Operating System or greater
  • Note: Low-density screens (240wx320h) are not supported
This answer has been viewed 374 times.
Go to main navigation